JDK Required: ‘tools.jar’ seems to be not in Studio classpath.

JDK Required: ‘tools.jar’ seems to be not in Studio classpath. Please ensure JAVA_HOME points to JDK rather than JRE.

Ubuntu veya farklı bir linux dağıtımı üzerine Android studio kurarken bu hata ile karşılaşıyorsanız işte çözümü burada.Forumlarda 2 saat boyunca aradım JDK sürümlerini değiştirdim yeni versiyonlar kurdum kaldırdım nafile fakat çözümü oldukça basit

ilk olarak terminal üzerinden tools.jar dosyasını arayalım ve dizinin bulalım

arama sonucu çıkan dizinden tools.jar dosyasını kopyalayın dosyayı bulamadıysa jdk indirerek kurunuz.tools.jar dosyasını  android studio yu indirdiğiniz dizine giderek android-studio/lib/ dizinine kopyalayın kurulumu tekrardan yapın sorun çözülecektir.

Kurulum esnasında  unable to run mksdcard sdk tool  gibi bir hata ile karşılaşırsanız ise  aşağıdaki paketi yükeleyip retry diyerek devam edin.

Ve son olarak kurulum sonrası bu sorunu yaşıyorsanız ve android studio açılmıyorsa default jre kurarak da sorunu çözebilirsiniz.

 

Site Footer